Jump to content
The MT-07 Forum

FZ07 not starting after restriction


Recommended Posts

Yesterday I was restricting my MT07 2019 with an Alphatechnik kit. I installed the MCR module. I then proceeded to start the engine up without any cables attached from the tank and thus the engine light came on. No biggie, plugged everything up and it started right up. I go to test ride it and the restriction seems to have worked. The next day I go outside to ride the bike and it just cranks. I go "oh shet" and quickly disassemble the tank and undo everything I had done the day before and after that the bike starts up and i reassemble everything. About 20 minutes later when I try to start it again it just doesn't work.


Here is what I've tried:

Filling up gas.

Using a charger atm. Using a multimeter it reads 12.6V but battery tender doesn't seem to be finished yet so it's still charging(?).

Push starting the bike.


All I hear when starting the bike is some switch noise and then just the engine cranking but never starting. Anyone knows what's up with my bike or do I have to take it to the shop?


Here's the manual for the restriction


Post with 1 votes and 1 views. Shared by Grevius1. Help


Edited by Grevus
Link to comment
Share on other sites

7 minutes ago, topazsparrow said:

Sorry to get off track, but I have to ask.

Why would you restrict your bike?

That's how the law works in EU.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.